Supported SQL Server Integration Services (SSIS) Versions #

  • SQL Server Integration Services (SSIS) 2012 SP4 (until 2022-07-12)
  • SQL Server Integration Services (SSIS) 2014 SP3 (until 2024-07-09)
  • SQL Server Integration Services (SSIS) 2016 SP2 (until 2026-07-14)
  • SQL Server Integration Services (SSIS) 2017 (until 2027-10-12)
  • SQL Server Integration Services (SSIS) 2019 (until 2030-01-08)

For development: SQL Server Data Tools are required to create SSIS packages. Use the related SSDT for the SQL Server Integration Services (SSIS) version you are using.
Check the Microsoft Help for details.

The version of the SQL Server Database used in SSIS to read or write data can differ from the version of the SQL Server Integration Services (SSIS) version, it means one can use e.g., SSIS version 2019 to write data to SQL Server Database version 2014.

Supported SAP Systems and releases #

All communication with SAP is performed via the RFC protocol. All SAP ABAP based systems that provide RFC connectivity are supported. The integration occurs at SAP application server level. Therefore, the database used by the SAP system is irrelevant. SAP ABAP Systems on any database (including HANA) are supported. This means that the operating system of the SAP system is irrelevant - all operating systems are supported. SAP Systems running on Big Endian and Little Endian hardware are supported.

SAP Releases 4.6C and newer are supported. Including the following:

  • mySAP
  • SAP Application Server ABAP, Message Server, Router, Standalone Gateway
  • SAP Business Suite 7 (CRM, SRM, SCM etc.)
  • SAP Business All in One, CAR, APO, PI, IS-U etc.
  • SAP BW 3.1 and later
  • SAP BW/BI 7.x
  • SAP BW/4HANA
  • SAP ERP / ECC 5.0 / ECC 6.0 (including all EhPs)
  • SAP R/3 Version 4.6C and later
  • SAP S/4HANA

The following SAP Releases have only limited support:

  • SAP S/4HANA Cloud Extended Edition (EX)

The installation of Custom Function Modules on SAP S/4HANA Cloud Extended Edition is not yet supported. Therefore the functionality of Table and Report extractions is limited for SAP S/4HANA Cloud Extended Edition.

HANA Database #

You can use Operational Data Provisioning (ODP) to connect the SAP HANA database of an SAP ABAP source system. Communication is done via RFC. With the ODP context for SAP HANA (HANA) the following HANA View types are available for extracting:

  • Analysis Views
  • Calculation Views
  • Associated Attribute Views

Direct access to a HANA database without an SAP ABAP source system running on the corresponding HANA database is not supported.

Not supported SAP systems #

Not supported are the SAP systems that don’t run on ABAP systems or don’t provide RFC connectivity. For example, the following systems are not supported:

  • Business By Design
  • Business One
  • Business Objects
  • Sybase
  • Ariba
  • Success Factors
  • Concur

Installation and Configuration on SAP #

Component SAP Release Requirements on the SAP system  
Table Rel. above 4.6C Installation of a custom function module is advisable.  
Table Join Rel. 7.0 or above Installation of a custom function module is necessary.  
BAPI & Function Module Rel. above 4.6C No special requirements. Note: Only remote-enabled functions are supported.  
Query Rel. above 4.6C No special requirements.  
Report Rel. above 4.6C Installation of a custom function module is necessary.  
BW Cube & InfoProvider Rel. above BW 3.1 No special requirements.  
BW Query Rel. above BW 3.1 No special requirements. Note: “Allow External Access to this Query” option is active  
Hierarchy Rel. above BW 3.1 No special requirements.  
ODP SAP_BASIS >= 730, BW >= 7,3X No special requirements.  
DeltaQ Rel. above 4.6C Customizing  
OHS Rel. above BW 3.5 Customizing  

For Information about the installation of the custom function modules and the SAP customizing, check the section SAP customizing.

SAP Authentication #

  • SAP user authentication (user name and password)
  • SAP authentication with Single Sign On (SSO) and kerberos
  • SAP Logon Ticket (via SAP Ticket Issuer) is also in some products available.
  • SAP system or dialog user with appropriate authority objects.

Ports #

Following ports have to be opened depending on the SAP system, where nn is the instance number of the SAP system (e.g. 00 or 99).

  • SAP Application Server: Port 33nn
  • SAP Message Server (Load Balancing): Port 36nn
  • Secure Communication Network (SCN): Port 48nn
  • SAP Router: Port 3399

SAP Licenses #

Additional SAP licenses might be required for extracting data from SAP. Contact SAP to verify these requirements.

Operating Systems #

  • Windows 10
  • Windows Server 2019
  • Windows 8.1 (until 10.01.2023)
  • Windows 7 SP1 (until 14.01.2020)
  • Windows Server 2016 (until 12.01.2027)
  • Windows Server 2012 R2 (until 10.10.2023)
  • Windows Server 2012 (until 10.10.2023)
  • Windows Server 2008 R2 SP1 (until 14.01.2020)
  • Windows Server 2008 SP2 (until 14.01.2020)

Other applications and frameworks #

.NET Framework 4.7.2 or higher. Download .NET Framework from the Microsoft website.

Hardware #

Memory

  • Minimum 4 GB.
    Depending on data volume, more memory may be required.

Disk space

  • 50 MB total for installation

32/64-Bit Environment

  • 32-Bit and 64-Bit operating systems