For establishing a connection to the HANA database the SAP HANA Data Provider for Microsoft ADO .NET is required.
This data provider is part of the SAP HANA Client setup.

ATTENTION: The HANA destination will only work with HANA data provider version 2.3.130.

Please install the SAP HANA Client 2.0 to install the required data provider.

For more information refer to SAP Help.