Required is the following:

Microstrategy Server including JSON API: version 10.10 or higher. User credentials with the appropriate rights to connect to the JSON API and create datasets and tables in Microstrategy.